Nous vous aidons à dépanner votre flipper.
Aide à la réparation des éléments électroniques et mécaniques
-
Conseils, trucs, astuces et
partage de nos expériences sur la restauration esthétique des éléments
Plateau / Playfield / Peinture & retouche / Mylar / Vernissage
-
Cours collectif sur le dépannage et
l'apprentissage aux techniques
-
Support Vidéo, Techniques
Expositions, Salons etc...
-
Nos partenaires Français…
-
A Bientôt sur www.flipper.fr
-
Mai 2008





Il y à des Gremlins dans mon Volcano...

Aller en bas

Il y à des Gremlins dans mon Volcano...

Message par Slamtilt le Mar 26 Déc 2017, 14:10

Salut à tous, 

Ce matin je veux me détendre sur une petite partie au Volcano, et encore une fois, j'ai des bugs avec en l'allumant... (Ce flipper est maudit, je n'arrête pas d'avoir des problèmes avec...)

Alors, 

Lancement d'une partie, Pas de sons ! Ah si, mais pas les bons, pas de "musique" (sons du volcan quoi) mais le SC-01 parle, et j'ai des sons mais pas les bons... (tilt, game over...) Le reste fonctionne bien (points bobines... jeu quoi) Je coupe le flip.
Je rallume 1min apres, 2e essai, idem.

Je me dit je vais faire la partie complète pour voir, et apres 5 bonnes minutes, paf, tout est rentré dans l'ordre d'un coup ! 

A savoir que depuis que j'ai acheté la carte sons evo, j'ai rencontré un paquet de problèmes avec cette derniere... 

C'est aussi le flipper qui avait une Driver qui faisait s'écrouler la tension là, rappellez-vous au salon de chalon 2016 ;-) J'ai fini par en acheter une autre. Cette dernière est maintenant détruite.

Et ensuite, j'ai remarqué que sur les afficheurs du bas (3 et 4) ils ont décidés de ne plus afficher les "1" comme ca du jour au lendemain. Des Gremlins dans ce jeu je vous dit... 

[Vous devez être inscrit et connecté pour voir cette image]
[Vous devez être inscrit et connecté pour voir cette image]

Bref, avez vous une idée de quoi regarder avant que ce genre de problème n'empire ? J'ai assez la trouille pour mon SC-01 je dois dire... 
Merci ;-)
avatar
Slamtilt
Initié
Initié

Localisation : Belgique
Nombre de messages : 194
Date d'inscription : 28/02/2015

Revenir en haut Aller en bas

Re: Il y à des Gremlins dans mon Volcano...

Message par noflip95 le Mer 27 Déc 2017, 19:53

Bonsoir, santa

Bon, pas de panique : pour le chiffre "1" qui a disparu des tableaux 3 et 4 ... faut juste aller à la chasse aux Gremlins, et ça tombe bien car c'est Noël.

Déjà, c'est pas la peine de chercher sur les afficheurs, car si ça n'affiche rien sur les tableaux 3 et 4, on peut être quasi-sûr que c'est le segment "h" qui déconne dans le groupe B (si, si  Twisted Evil ). Et ça, c'est pas dans les afficheurs !

Sur les afficheurs SYS80, le chiffre "1" est géré par un signal spécifique dit "segment h". Il est commun à un "groupe". Sur les SYS80, tu as trois groupes : A pour les afficheurs 1 et 2, B pour les 3 et 4, et C... pour le reste (crédits, balls).

Regarde dans le schéma de câblage, tu va voir qu'il y a un fil (couleur 677) qui va du connecteur A1J2 (sortie CPU) vers les displays 3 et 4.
Si le segment h est manquant, alors c'est très probablement un mauvais contact et en particulier sur le contact n° 16. Tu débranche le A1J2, tu contrôle, tu mets un coup de gomme abrasive pour nettoyer la bande contacts sur la CPU, et tu vérifie aussi que le connecteur n'est pas cassé.
Il y a 99% de chances que le problème vienne du connecteur. Possible aussi que le fil soit coupé, mais c'es quand même rare (tu peut contrôler la continuité à l'ohmmètre).
[Vous devez être inscrit et connecté pour voir cette image]

Parce que si ca ne vient pas de là, alors il est aussi possible que il y ait un circuit cramé sur la carte CPU :
[Vous devez être inscrit et connecté pour voir cette image]
Le signal "segment h" du groupe B est piloté directement par le RIOT U5 et par un driver 7404 (Z16). Il est possible que ce dernier soit mort, mais ca serait quand même très étonnant, car quand le circuit crame, en général il n'y a plus rien qui marche (donc plus d'affichage, ni de segment h dans le groupe A).
Donc hypothèse très peu probable.

En revanche, le coup du mauvais contact dans le connecteur A1J2, c'est un grand classique.

_________________


Thierry.
avatar
noflip95
Modérateur
Modérateur

Localisation : Franconville (95)
Nombre de messages : 680
Age : 53
Date d'inscription : 12/09/2010

https://www.flipprojets.fr

Revenir en haut Aller en bas

Re: Il y à des Gremlins dans mon Volcano...

Message par Slamtilt le Sam 30 Déc 2017, 14:22

C'est comme toujours sur ce forum diablement bien expliqué :-) 

J'adore ton schéma avec le Gremlins dessus ;-) Arfff

Dés que j'ai 5 min je regardes cela.

Merci :-)

Et pour la carte sons qui n'en fait qu'a sa tête t'as une idée la comme ca ?
avatar
Slamtilt
Initié
Initié

Localisation : Belgique
Nombre de messages : 194
Date d'inscription : 28/02/2015

Revenir en haut Aller en bas

Re: Il y à des Gremlins dans mon Volcano...

Message par flip78 le Dim 31 Déc 2017, 10:11

Bonjour,

Pour les sons, vérifie la connectique en premier lieu.

Les commandes son passent par la driver et un circuit 7404, ensuite son traitées par un autre 7404 sur la carte son.

Si la carte fonctionne déjà comme cela, le SC-01 ne craint rien, c'est uniquement les commandes son qui sont envoyées par la cpu qui ne sont pas bien interprétées.

C'est génant mais pas dramatique il faut suivre les 6 signaux qui arrivent au niveau du 6532 pour être sur.

Attention si tu dessoudes toi même le 7404, le 74LS30 ou  le LM393, (ces circuits sont souvent coupables mais faut tester avant de changer, hein !) le circuit imprimé est fragile et si tu n'a pas l'habitude le résultat est catastrophique ... (j'ai déjà du réparer des "boucheries")

_________________


Hmm, Hmmm, Qu'a dit le monstre à trois têtes ? Ne vous mêlez pas de choses que vous ne comprenez pas.

--- PIECE OF MIND ---
avatar
flip78
Modérateur
Modérateur

Localisation : Yvelines
Nombre de messages : 1200
Age : 54
Emploi/loisirs : Informatique / Electronique, flippers, musique
Date d'inscription : 28/07/2008

http://www.flipprojets.fr/

Revenir en haut Aller en bas

Re: Il y à des Gremlins dans mon Volcano...

Message par Slamtilt le Mar 02 Jan 2018, 09:18

Pour les 7404 j'en ai déjà fait les frais je ne le cache pas (par le passé je veux dire) la moitié des rivets sont partis avec ! :-(

D'ailleurs, c'est quoi le mieux, déssouder le vieux composant ou le couper net et enlever les restes (dans le cas ou tu es sur qu'il est foutu hein) 

Déssouder proprement une puce pour le moment je n'y arrives pas, ma pompe a déssouder me laisse toujours bien un peu d'étain le truc ne bouge pas, si tu forces, ben la oui cata...
avatar
Slamtilt
Initié
Initié

Localisation : Belgique
Nombre de messages : 194
Date d'inscription : 28/02/2015

Revenir en haut Aller en bas

Re: Il y à des Gremlins dans mon Volcano...

Message par philippe91 le Mar 02 Jan 2018, 09:50

Salut

le mieux a mon avis est de coupé les pattes du composant au ras de celui-ci pas au ras du PCB de maniere a avoir les pattes les plus longue possible et après ont les enlevent une par une avec le fer a souder

@++
avatar
philippe91
Modérateur
Modérateur

Localisation : Ile de france 91
Nombre de messages : 334
Age : 62
Date d'inscription : 19/06/2013

Revenir en haut Aller en bas

Re: Il y à des Gremlins dans mon Volcano...

Message par flip78 le Mar 02 Jan 2018, 10:41

Bonjour,

Quand je dois dé-souder un composant, c'est que je suis sur qu'il faille le changer.
A de rares exceptions il faut changer 2 composants car impossible de savoir lequel des 2 est en panne.

Perso je vais plus vite à couper les pattes des composants. Tout dépend du composant bien sur !
Les 8 14 16 18 pattes je coupe sauf s'il s'agit d'un composant qui coûte cher.
Pour les plus gros je dessoude, mais bon disons que j'ai le matos et le savoir faire.

Par exemple une PAL ou GAL ou plus rarement EPROM faut dé-souder pour la tester !

Mais une fois le composant extrait, il faut nettoyer et ré-étamer le PCB avant de mettre un support !

_________________


Hmm, Hmmm, Qu'a dit le monstre à trois têtes ? Ne vous mêlez pas de choses que vous ne comprenez pas.

--- PIECE OF MIND ---
avatar
flip78
Modérateur
Modérateur

Localisation : Yvelines
Nombre de messages : 1200
Age : 54
Emploi/loisirs : Informatique / Electronique, flippers, musique
Date d'inscription : 28/07/2008

http://www.flipprojets.fr/

Revenir en haut Aller en bas

Re: Il y à des Gremlins dans mon Volcano...

Message par Slamtilt le Sam 13 Jan 2018, 12:30

J'essayerais tiens la prochaine fois de couper les pattes à ras du composant pour les retirer ensuite apres, c'est tout sauf con comme technique !  Very Happy
avatar
Slamtilt
Initié
Initié

Localisation : Belgique
Nombre de messages : 194
Date d'inscription : 28/02/2015

Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum